Welcome! Log In Create A New Profile

Advanced

[PHP] PECL Mongo 1.6.15 - PHP Fatal error: Class 'Mongo' not found

Posted by Poil 
Hi,

When running mongo PECL library 1.6.15 I have this error. " Class
'Mongo' not found  in ....."

Rollbacking to 1.6.14 all is working fine.

Anyone with the same issue ? (Ubuntu 14.04 - PHP 5.5.9-1ubuntu4.14)

Best regards,


--
PHP General Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php
When running on CLI, I have got this error

PHP Warning:  PHP Startup: Unable to load dynamic library
'/usr/lib/php5/20121212/mongo.so' - /usr/lib/php5/20121212/mongo.so:
undefined symbol: php_mongo_matches_san_list in Unknown on line 0


Le 04/09/2017 à 21:31, Poil a écrit :
> Hi,
>
> When running mongo PECL library 1.6.15 I have this error. " Class
> 'Mongo' not found  in ....."
>
> Rollbacking to 1.6.14 all is working fine.
>
> Anyone with the same issue ? (Ubuntu 14.04 - PHP 5.5.9-1ubuntu4.14)
>
> Best regards,
>
>


--
PHP General Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php
> 4 sep. 2017 kl. 21:33 skrev Poil <[email protected]>:
>
> When running on CLI, I have got this error
>
> PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20121212/mongo.so' - /usr/lib/php5/20121212/mongo.so: undefined symbol: php_mongo_matches_san_list in Unknown on line 0
>
>
> Le 04/09/2017 à 21:31, Poil a écrit :
>> Hi,
>>
>> When running mongo PECL library 1.6.15 I have this error. " Class 'Mongo' not found in ....."
>>
>> Rollbacking to 1.6.14 all is working fine.
>>
>> Anyone with the same issue ? (Ubuntu 14.04 - PHP 5.5.9-1ubuntu4.14)
>>
>> Best regards,
>>
>>

Hi.

Actually, I have no idea. But it seems that the PECL mongo driver is no longer supported / actively developed. From mongodb.com:

"The mongo extension available from PECL is an older, legacy driver for PHP 5.x. The mongo extension is no longer maintained and new projects are advised to use the mongodb extension and PHP library. A community-developed Mongo PHP Adapter project implements the legacy mongo extension’s API using the new mongodb extension and PHP library, which may be useful for those wishing to migrate existing applications."

If you are stuck with PHP 5.5, maybe you could try the mongo-db-adapter (https://github.com/alcaeus/mongo-php-adapter https://github.com/alcaeus/mongo-php-adapter)?

Regards,
Frank
Sorry, only registered users may post in this forum.

Click here to login