Welcome! Log In Create A New Profile

Advanced

[PHP-DEV] version of bundled libzip in sources

Posted by Hajo Locke 
Hajo Locke
[PHP-DEV] version of bundled libzip in sources
August 30, 2018 09:50AM
Hello List,

in php7.2 i try to use ZipArchive::setEncryptionNamewith with no success
(Call to undefined method).
according to the docs of PECL zip these methods are available with
libzip >= 1.2.0

In latest source php-7.2.9/ext/zip/lib version of bundled lib is 1.1.2.
So zip extension cant play its full potential, because bundled base-lib
is outdated.
As alternative i could compile with --with-libzip=DIR instead of
--enable-zip, but this requires replacement of system-libs to newer
versions, which in most cases causes more effort, because unknown number
of systemsoftware is compiled against systems libzip.

Are there plans to raise version of supplied libzip to use its full
range if functions?

Thanks,
Hajo
Remi Collet
Re: [PHP-DEV] version of bundled libzip in sources
August 30, 2018 11:00AM
Le 30/08/2018 à 09:47, Hajo Locke a écrit :
> Hello List,
>
> in php7.2 i try to use ZipArchive::setEncryptionNamewith with no success
> (Call to undefined method).
> according to the docs of PECL zip these methods are available with
> libzip >= 1.2.0
>
> In latest source php-7.2.9/ext/zip/lib version of bundled lib is 1.1.2.
> So zip extension cant play its full potential, because bundled base-lib
> is outdated.
> As alternative i could compile with --with-libzip=DIR instead of
> --enable-zip, but this requires replacement of system-libs to newer
> versions, which in most cases causes more effort, because unknown number
> of systemsoftware is compiled against systems libzip.
>
> Are there plans to raise version of supplied libzip to use its full
> range if functions?

No.

Plan is to only support system library (as other extensions, e.g.
openssl, intl, pcre, ...)

Bundled lib is only there because of travis, but should be dropped ASAP.

Remi
Hajo Locke
Re: [PHP-DEV] version of bundled libzip in sources
August 30, 2018 11:50AM
Hello,

Am 30.08.2018 um 10:50 schrieb Remi Collet:
> Le 30/08/2018 à 09:47, Hajo Locke a écrit :
>> Hello List,
>>
>> in php7.2 i try to use ZipArchive::setEncryptionNamewith with no success
>> (Call to undefined method).
>> according to the docs of PECL zip these methods are available with
>> libzip >= 1.2.0
>>
>> In latest source php-7.2.9/ext/zip/lib version of bundled lib is 1.1.2.
>> So zip extension cant play its full potential, because bundled base-lib
>> is outdated.
>> As alternative i could compile with --with-libzip=DIR instead of
>> --enable-zip, but this requires replacement of system-libs to newer
>> versions, which in most cases causes more effort, because unknown number
>> of systemsoftware is compiled against systems libzip.
>>
>> Are there plans to raise version of supplied libzip to use its full
>> range if functions?
> No.
>
> Plan is to only support system library (as other extensions, e.g.
> openssl, intl, pcre, ...)
>
> Bundled lib is only there because of travis, but should be dropped ASAP.
ok, thanks. so i try to update my system-libs or use the zip-binary.
Most OS have very old libzip-libs. New Ubuntu 18.04 LTS  currently
delivers 1.1.2 as well as 18.10 beta, so we will wait some years for
wide systemsupport.
>
> Remi
>
Thanks,
Hajo


--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
Sorry, only registered users may post in this forum.

Click here to login