Welcome! Log In Create A New Profile

Advanced

[PHP-DEV] ext/sqlite3 module version

Posted by Christoph M. Becker 
Christoph M. Becker
[PHP-DEV] ext/sqlite3 module version
January 07, 2017 06:40PM
Hi!

I've just noticed that ext/sqlite3 reports the following in the PHP info
(all version incl. current master):

SQLite3 module version: 0.7-dev

That's obviously a relict of when PECL/sqlite3 has been moved to
ext/sqlite3 in 2008, and has since been forgotten about.

I don't think that having an own version for a bundled extension makes
much sense, but at least the version should be changed to something
reasonable – certainly it's not a dev version anymore.

Thoughts?

--
Christoph M. Becker

--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
Kalle Sommer Nielsen
Re: [PHP-DEV] ext/sqlite3 module version
January 07, 2017 06:40PM
Hi Christoph

2017-01-07 18:32 GMT+01:00 Christoph M. Becker <[email protected]>:
> Hi!
>
> I've just noticed that ext/sqlite3 reports the following in the PHP info
> (all version incl. current master):
>
> SQLite3 module version: 0.7-dev
>
> That's obviously a relict of when PECL/sqlite3 has been moved to
> ext/sqlite3 in 2008, and has since been forgotten about.
>
> I don't think that having an own version for a bundled extension makes
> much sense, but at least the version should be changed to something
> reasonable – certainly it's not a dev version anymore.
>
> Thoughts?

Either NO_VERSION_YET (I think its called) or PHP_VERSION should be
fine tbh. Argubly the first one is awkward considering it was once a
PECL extension, but it was only short lived afair before it got merged
to PHP 5.3.0 back then.


--
regards,

Kalle Sommer Nielsen
kalle@php.net

--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
Sorry, only registered users may post in this forum.

Click here to login