Welcome! Log In Create A New Profile

Advanced

Re: [PHP-DEV] php_firebird

Posted by Lester Caine 
Lester Caine
Re: [PHP-DEV] php_firebird
October 13, 2008 09:10AM
Pierre Joye wrote:
> On Fri, Oct 10, 2008 at 4:54 PM, marius popa <[email protected]> wrote:
>> On Fri, Oct 10, 2008 at 3:50 PM, Pierre Joye <[email protected]> wrote:
>>> hi Lester,
>>>
>>> On Tue, Oct 7, 2008 at 8:18 PM, Lester Caine <[email protected]> wrote:
>>>> What is the correct procedure to create a new driver, or rather clone the
>>>> existing php_interbase so that we can build a proper Firebird version that
>>>> actually uses the fbclient.dll rather than sharing the now incompatible
>>>> GDS32.DLL client. Some people are starting to use Interbase in parallel with
>>>> Firebird, but the driver can only access one client :(
>>> I wonder where ended our discussions about fixing firebird/interbase
>>> issues on windows. Despite my reminders, I saw nothing from any of the
>>> volunteers. It is very unlikely that I or any other will take care of
>>> these drivers any time soon. That means that it is likely to do not be
>>> present at all in 5.3.0+ (windows).
>> The only bugs left are the one with blobs
>> http://bugs.php.net/search.php?cmd=display&status=Open&bug_type%5B%5D=InterBase+related
>>
>> and i think the failed events tests from the extension directory
>>
>> Please tell us what issues are still present on windows ?
>
> No build are done and none are planed in a near future without a
> significant effort from the actual users or developers of the
> firebird/interbase drivers.

The 5.2.6 Windows build is not NOW showing any of the problems introduced with
the changes to the 5.2.x builds. There MAY still be a problem with 64 bit
builds for Linux, but it's been difficult to actually prove anything.

So WHAT THE F**K are you expecting from us? We just need *ANY* windows 5.2.7
compilation to test, and the last 5.3.0 build was working fine but until the
'discussion' on other areas are concluded there seems little point doing any
further testing?

FIREBIRD has pulled somewhat further ahead and needs it's own build for that,
but there has still been no response on how we can achieve that! And until the
windows snapshot builds are actually being produced it's difficult to test
anything :(

--
Lester Caine - G8HFL
-----------------------------
Contact - http://lsces.co.uk/lsces/wiki/?page=contact
L.S.Caine Electronic Services - http://lsces.co.uk
EnquirySolve - http://enquirysolve.com/
Model Engineers Digital Workshop - http://medw.co.uk//
Firebird - http://www.firebirdsql.org/index.php

--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
Pierre Joye
Re: [PHP-DEV] php_firebird
October 13, 2008 11:45AM
hi Lester,

On Mon, Oct 13, 2008 at 9:06 AM, Lester Caine <[email protected]> wrote:

I'm not sure what else we can say but you should really read your mail
archives and the discussions we had 6 months ago about what we need to
get firebird support back in 5.3.0 windows binaries.

PHP 5.3.0 builds (releases or snapshots) have no firebird since day
#1, I wonder what you have tested.

> FIREBIRD has pulled somewhat further ahead and needs it's own build for
> that, but there has still been no response on how we can achieve that!

That's what we asked to have. We do not not use firebird, we have no
clue about the versions to use, the configuration or anything else. We
do not have the time and the resources to figure it out either and
that's why we asked you (as you Lester and the other person having
volunteered to provide the info) to provide these info.

Instead of talking about forks and pointing the stinky fingers to
internals (http://tech.groups.yahoo.com/group/firebird-php/message/2561),
you may finally do some your home work.

Cheers,
--
Pierre

http://blog.thepimp.net | http://www.libgd.org

--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
Lester Caine
Re: [PHP-DEV] php_firebird
October 13, 2008 10:40PM
Pierre Joye wrote:
> hi Lester,
>
> On Mon, Oct 13, 2008 at 9:06 AM, Lester Caine <[email protected]> wrote:
>
> I'm not sure what else we can say but you should really read your mail
> archives and the discussions we had 6 months ago about what we need to
> get firebird support back in 5.3.0 windows binaries.
WHAT IS STILL OUTSTANDING? We tested 5.2.x, identified the problems and WHEN I
windows build of 5.2.7RC appears we can test that! I'm not seeing anything
outstanding on the bug list for WINDOWS.
For people running Interbase AND Firebird we need to identify the different
clients but that is basically just a single line change in the code, so
perhaps we should be adding a switch for that rather than talking about a
separate port, however some people seem to want both running at the same time
which causes a problem with just having one driver?

> PHP 5.3.0 builds (releases or snapshots) have no firebird since day
> #1, I wonder what you have tested.
PHP5_3_080615
This has a php_interbase build that is working fine. The only problems I have
with this copy of 5.3.0 is all the NONE database error messages that it's
throwing in my various projects. But UNTIL there is agreement on what is going
to be the final version of 5.3.0 there is little point trying to fix them !!!

>> FIREBIRD has pulled somewhat further ahead and needs it's own build for
>> that, but there has still been no response on how we can achieve that!
>
> That's what we asked to have. We do not not use firebird, we have no
> clue about the versions to use, the configuration or anything else. We
> do not have the time and the resources to figure it out either and
> that's why we asked you (as you Lester and the other person having
> volunteered to provide the info) to provide these info.
The LAST request was that we simply tested things on windows - compiling
builds was not a problem? This we have been doing but since *WE* can't build
compatible windows binaries, we are reliant on the snapshot builds - which are
currently not happening for windows?
We never got an answer as to what was wrong with php_interbase i.e. what needs
doing to it to cater for the rewrite required for PHP5.3?

> Instead of talking about forks and pointing the stinky fingers to
> internals (http://tech.groups.yahoo.com/group/firebird-php/message/2561),
> you may finally do some your home work.
THAT problem relates to LINUX - but *I* have not been able to find it. MY 64
bit Linux systems are fine!!! So until someone can identify a faulty setup we
are a little stuffed :(

And KILLING php_interbase is not a solution to anything. If you do not want us
to use PHP then fine. I'm sure we can all scrap several years of work and
switch to something else. But we don't actually have a problem - we just never
advance beyond 5.2.x. And forcing weeks of unproductive activity trying to
create a PDO driver that does EVERYTHING that php_interbase CURRENTLY provides
is not a practical option either. We have already established that ADOdb
running in PDO mode is slower than the equivalent native drivers, so its
simply not a practical way forward.

I suppose the other option is to simply clone php_interbase outside the PHP
project and do our own builds? But support for windows will not happen that way :(

--
Lester Caine - G8HFL
-----------------------------
Contact - http://lsces.co.uk/lsces/wiki/?page=contact
L.S.Caine Electronic Services - http://lsces.co.uk
EnquirySolve - http://enquirysolve.com/
Model Engineers Digital Workshop - http://medw.co.uk//
Firebird - http://www.firebirdsql.org/index.php

--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
Pierre Joye
Re: [PHP-DEV] php_firebird
October 13, 2008 11:45PM
Hi Lester,

On Mon, Oct 13, 2008 at 10:36 PM, Lester Caine <[email protected]> wrote:

>> I'm not sure what else we can say but you should really read your mail
>> archives and the discussions we had 6 months ago about what we need to
>> get firebird support back in 5.3.0 windows binaries.
>
> WHAT IS STILL OUTSTANDING?

I would greatly appreciate if you stop to write using upper cases for
every two sentences or words.

About killing FB, if I was trying to kill it, it would be in siberia
already. Please read my last post to the firebird-php list (when the
moderators let it through, did I mention that moderated lists are
bad?). But I said nothing else that what I told you months ago
already.

Cheers,
--
Pierre

http://blog.thepimp.net | http://www.libgd.org

--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
Lester Caine
Re: [PHP-DEV] php_firebird
October 14, 2008 06:20AM
Pierre Joye wrote:
> Hi Lester,
>
> On Mon, Oct 13, 2008 at 10:36 PM, Lester Caine <[email protected]> wrote:
>
>>> I'm not sure what else we can say but you should really read your mail
>>> archives and the discussions we had 6 months ago about what we need to
>>> get firebird support back in 5.3.0 windows binaries.
>> WHAT IS STILL OUTSTANDING?
>
> I would greatly appreciate if you stop to write using upper cases for
> every two sentences or words.
>
> About killing FB, if I was trying to kill it, it would be in siberia
> already. Please read my last post to the firebird-php list (when the
> moderators let it through, did I mention that moderated lists are
> bad?). But I said nothing else that what I told you months ago
> already.

I'm a moderator on that list :(
Obviously something is wrong since I've had no message for a pending post!
Strange since there are numerous messages for the trash that initial
moderation controls. On most of the list I moderate the crap exceeds the
legitimate posts at times - but if you want that included ....

And I do not apologise for the upper case since the context is totally
relevant. I THOUGHT that there had been agreement HERE that all we - the users
- needed to do was test and report - the system would provide the relevant
builds. This is the current status on the 5.2.7 builds - which we are waiting
for a windows version to test - but I had not realised that the 5.3 build I
have is possibly one of the last with the php_interbase driver :( And the
upper case above is relevant since I see nothing telling us why there is no
5.3 builds now?

But I'll continue this on the firebird-php list ....

--
Lester Caine - G8HFL
-----------------------------
Contact - http://lsces.co.uk/lsces/wiki/?page=contact
L.S.Caine Electronic Services - http://lsces.co.uk
EnquirySolve - http://enquirysolve.com/
Model Engineers Digital Workshop - http://medw.co.uk//
Firebird - http://www.firebirdsql.org/index.php

--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php
Sorry, only registered users may post in this forum.

Click here to login