Welcome! Log In Create A New Profile

Advanced

Some problems after compilation (file/folder/processus creation)

Posted by PiAil 
Hi,

I am trying to compile Nginx with Visual Studio 2015, as a project. I
followed this tutorial :
https://stackoverflow.com/questions/21486482/compile-nginx-with-visual-studio/22649559#22649559
, which worked pretty well (even if it was made for VS 2010).

I was finally able to launch nginx.exe but the webserver doesn't work yet,
several things :

1. Release mode

The program exits with the messages :

"The thread 0x25ac has exited with code 2 (0x2).
The thread 0xe64 has exited with code 2 (0x2).
The thread 0x1a60 has exited with code 2 (0x2).
The program '[13872] nginx.exe' has exited with code 2 (0x2)."

The error.log file contains :

"2018/05/28 15:26:09 [crit] 13872#4024:
CreateProcess("my\nginx\path\Nginx\Release\nginx.exe") failed (5:
FormatMessage() error:(15100))"

2. Debug Mode

The program exits with the messages :

"The thread 0x18a8 has exited with code 1 (0x1).
The thread 0x3064 has exited with code 1 (0x1).
The thread 0x2bbc has exited with code 1 (0x1).
The program '[6868] Nginx.exe' has exited with code 1 (0x1)."

The error.log file contains :

"2018/05/28 14:14:25 [emerg] 13152#14248: CreateDirectory()
"my/nginx/path/Nginx/Debug/temp/client_body_temp" failed (123:
FormatMessage() error:(15100))"

Here's the arborescence of my/nginx/path/Nginx/Debug/ and
my/nginx/path/Nginx/Release/ :

"nginx.exe
conf/
nginx.conf
a bunch of other conf files
html/
index.html
logs/
error.log
acces.log
nginx.pid
temp/
client_body_temp/"

Note : I myself created the different files and folder, the program was
unable to do it.

3. nginx.conf

Last, I'm unable to modify the path of, e.g, my error.log in nginx.conf.
When I try to do it, it seems to have no effect at all.The command

"error_log logs/error_bis.log;"

does not create error_bis.log or does not write in it if I create the file.


Note : I have the admin privileges.

I would be really thankful for some help.

Posted at Nginx Forum: https://forum.nginx.org/read.php?2,279971,279971#msg-279971

_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
Hello!

On Tue, May 29, 2018 at 03:57:56AM -0400, PiAil wrote:

> I am trying to compile Nginx with Visual Studio 2015, as a project. I
> followed this tutorial :
> https://stackoverflow.com/questions/21486482/compile-nginx-with-visual-studio/22649559#22649559
> , which worked pretty well (even if it was made for VS 2010).
>
> I was finally able to launch nginx.exe but the webserver doesn't work yet,
> several things :

You should be able to launch nginx.exe once you've followed "step
1" of the tutorial linked above, which essentially instructs to
follow this howto:

http://nginx.org/en/docs/howto_build_on_win32.html

Try compling working nginx version using this howto first.

--
Maxim Dounin
http://mdounin.ru/
_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
Thanks for your answer,

I already did that step the first time I compiled it. After some
investigation, I find out that CreateDirectory was called with an unsigned
char* whereas it should be a LPWSTR. Could the problem come from here ? If
so, is it possible to patch this easily ?

Posted at Nginx Forum: https://forum.nginx.org/read.php?2,279971,279986#msg-279986

_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
Just had to set "Character Set" (in Property->General->Project Defaults)
from "Unicode" to "No set". Everything works now.

Posted at Nginx Forum: https://forum.nginx.org/read.php?2,279971,279989#msg-279989

_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
Sorry, only registered users may post in this forum.

Click here to login