Welcome! Log In Create A New Profile

Advanced

HTTP/2 seems slow

Posted by GuiltyNL 
GuiltyNL
HTTP/2 seems slow
March 15, 2017 11:10AM
Hi guys,

I'm working on a HTTP/2 website solution and when testing we can see HTTP/2
works.

The thing is that everything loads at the same time, but very slow. While
the bandwith cannot be the problem.

At the end HTTP/2 is a bit slower than HTTP/1.1

For example:

When I use HTTP/1.1 I have 5 files loading after each other. The time to
first byte needed per file is between 13 and 20 ms (plus some loading time)
When I use HTTP/2 The same 5 files load at the same time, but the time to
first byte needed per file is between 40 to 60 ms. (plus some loading
time).

Where do I need to look?

Posted at Nginx Forum: https://forum.nginx.org/read.php?2,272944,272944#msg-272944

_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
GuiltyNL
Re: HTTP/2 seems slow
March 15, 2017 11:10AM
BTW I did read this:

https://www.section.io/blog/Why-do-I-see-long-TTFB-with-HTTP2-in-WebPageTest/

But I would expect that the page itself would load (a bit) faster, and that
is not the case:

HTTP/1.1 Document Complete 1,777 sec
HTTP/2 Document Complete 2,128 sec

Posted at Nginx Forum: https://forum.nginx.org/read.php?2,272944,272946#msg-272946

_______________________________________________
nginx mailing list
nginx@nginx.org
http://mailman.nginx.org/mailman/listinfo/nginx
Sorry, only registered users may post in this forum.

Click here to login