Welcome! Log In Create A New Profile

Advanced

Re: [PATCH 1076/1285] Replace numeric parameter like 0444 with macro

Posted by Steven Rostedt 
On Tue, 2 Aug 2016 20:14:16 +0800
Baole Ni <baolex.ni@intel.com> wrote:

> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.
>

NACK!

I find 0444 more readable than S_IRUSR | S_IRGRP | S_IROTH.

-- Steve

> Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
> Signed-off-by: Baole Ni <baolex.ni@intel.com>
> ---
> kernel/time/sched_clock.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/kernel/time/sched_clock.c b/kernel/time/sched_clock.c
> index a26036d..9d072c3 100644
> --- a/kernel/time/sched_clock.c
> +++ b/kernel/time/sched_clock.c
> @@ -71,7 +71,7 @@ struct clock_data {
> static struct hrtimer sched_clock_timer;
> static int irqtime = -1;
>
> -core_param(irqtime, irqtime, int, 0400);
> +core_param(irqtime, irqtime, int, S_IRUSR);
>
> static u64 notrace jiffy_sched_clock_read(void)
> {
Sorry, only registered users may post in this forum.

Click here to login