Welcome! Log In Create A New Profile

Advanced

[PATCH 1233/1285] Replace numeric parameter like 0444 with macro

Posted by Baole Ni 
I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <[email protected]>
Signed-off-by: Baole Ni <[email protected]>
---
sound/pci/hda/patch_hdmi.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/sound/pci/hda/patch_hdmi.c b/sound/pci/hda/patch_hdmi.c
index d0d5ad8..6107c13 100644
--- a/sound/pci/hda/patch_hdmi.c
+++ b/sound/pci/hda/patch_hdmi.c
@@ -45,7 +45,7 @@
#include "hda_jack.h"

static bool static_hdmi_pcm;
-module_param(static_hdmi_pcm, bool, 0644);
+module_param(static_hdmi_pcm, bool, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
MODULE_PARM_DESC(static_hdmi_pcm, "Don't restrict PCM parameters per ELD info");

#define is_haswell(codec) ((codec)->core.vendor_id == 0x80862807)
--
2.9.2
Sorry, only registered users may post in this forum.

Click here to login