Welcome! Log In Create A New Profile

Advanced

[PATCH 1134/1285] Replace numeric parameter like 0444 with macro

Posted by Baole Ni 
I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <[email protected]>
Signed-off-by: Baole Ni <[email protected]>
---
net/sched/sch_htb.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/net/sched/sch_htb.c b/net/sched/sch_htb.c
index d4b4218..8234fae 100644
--- a/net/sched/sch_htb.c
+++ b/net/sched/sch_htb.c
@@ -62,11 +62,11 @@ static int htb_hysteresis __read_mostly = 0; /* whether to use mode hysteresis f
#endif

/* Module parameter and sysfs export */
-module_param (htb_hysteresis, int, 0640);
+module_param (htb_hysteresis, int, S_IRUSR | S_IWUSR | S_IRGRP);
MODULE_PARM_DESC(htb_hysteresis, "Hysteresis mode, less CPU load, less accurate");

static int htb_rate_est = 0; /* htb classes have a default rate estimator */
-module_param(htb_rate_est, int, 0640);
+module_param(htb_rate_est, int, S_IRUSR | S_IWUSR | S_IRGRP);
MODULE_PARM_DESC(htb_rate_est, "setup a default rate estimator (4sec 16sec) for htb classes");

/* used internaly to keep status of single class */
--
2.9.2
Sorry, only registered users may post in this forum.

Click here to login