Welcome! Log In Create A New Profile


[PATCH 1232/1285] Replace numeric parameter like 0444 with macro

Posted by Baole Ni 
I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <[email protected]>
Signed-off-by: Baole Ni <[email protected]>
sound/pci/hda/hda_tegra.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/sound/pci/hda/hda_tegra.c b/sound/pci/hda/hda_tegra.c
index 17fd817..4c00aa8 100644
--- a/sound/pci/hda/hda_tegra.c
+++ b/sound/pci/hda/hda_tegra.c
@@ -78,7 +78,7 @@ struct hda_tegra {

#ifdef CONFIG_PM
static int power_save = CONFIG_SND_HDA_POWER_SAVE_DEFAULT;
-module_param(power_save, bint, 0644);
+module_param(power_save, bint, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
"Automatic power-saving timeout (in seconds, 0 = disable).");
Sorry, only registered users may post in this forum.

Click here to login