Welcome! Log In Create A New Profile

Advanced

[PATCH] MAJOR: spoe: upgrade the SPOP version to 2.0 and remove the support for 1.0

Posted by Christopher Faulet 
Hi,

Here is a patch to change the SPOP version. It follows the commit
c4dcaff3 ("BUG/MEDIUM: spoe: Flags are not encoded in network order") in
order to make sure no incompatible agent will be used with HAProxy. To
do so, the SPOP 1.0 is no more supported.

Thanks,
--
Christopher Faulet
Hi Christopher,

On Mon, Jun 04, 2018 at 02:52:31PM +0200, Christopher Faulet wrote:
> Here is a patch to change the SPOP version. It follows the commit c4dcaff3
> ("BUG/MEDIUM: spoe: Flags are not encoded in network order") in order to
> make sure no incompatible agent will be used with HAProxy. To do so, the
> SPOP 1.0 is no more supported.

Now merged, thank you. While I hate to perform such breaking changes,
here we're already facing a broken situation so I agree that it's better
to benefit from the moment where the only existing SPOAs are those
located in the contrib/ directory and fix the issue once for all, to
ensure nobody accidently starts to develop an outdated version that will
break once heavily deployed.

Thanks,
Willy
Sorry, only registered users may post in this forum.

Click here to login